Renault Wind Owners
Welcome to the Forum

For the best experience and to see exclusive content, we encourage you to register and login, either using our native login, or the TopicIt system.

If however you do not wish to register, then please close this window.

Wind radio issue

Go down

Wind radio issue

Post by Colin7834 on Sun 13 Jan 2019 - 11:46

My wife drives a wind and after a few months of driving the radio stopped working. It still comes on but just static sound. I've had a quick look online and can't even confirm whether or not the car should have an aeriel. Any advice greatly appreciated.

Colin7834
Started the engine

Posts : 5
Join date : 2019-01-13

View user profile

Back to top Go down

Re: Wind radio issue

Post by Mistydogblue on Sun 13 Jan 2019 - 12:26

The aerial is built into the rear window and it is possible that the connection between the aerial and the window has broken. This is a common problem with this type of aerial. The connection and amplifier are in the bottom left hand side of the window - to check you will have to remove the plastic trim around the window but this just pulls off.

Is the cd player still working ok?

Mistydogblue
Set the stereo

Posts : 24
Join date : 2018-08-01

View user profile

Back to top Go down

Re: Wind radio issue

Post by Colin7834 on Sun 13 Jan 2019 - 13:17

Thanks for the reply. Yeah the CD player us still working. I'll go and have a look at the window now.

Colin7834
Started the engine

Posts : 5
Join date : 2019-01-13

View user profile

Back to top Go down

Re: Wind radio issue

Post by Colin7834 on Sun 13 Jan 2019 - 13:31

Just had a look the connection looks ok

Colin7834
Started the engine

Posts : 5
Join date : 2019-01-13

View user profile

Back to top Go down

Re: Wind radio issue

Post by Mistydogblue on Sun 13 Jan 2019 - 19:46

Ok, if the aerial seems ok then the only other component that could be faulty is the stereo itself. Before going out to replace the stereo i would do a further check on the aerial by using a multimeter to check the continuity at both ends of the aerial (the end that plugs into the stereo and the end at the rear window) but it is most unlikely that the cable has been damaged. It is also difficult to plug in a different stereo to test the aerial because the Wind does not use the standard aerial fittings - it uses fraka fittings and the only way to use a different one would be to buy a fraka aerial adaptor from ebay for about £4 or £5. Alternatively you could take the stereo to someone who has the equipment to test it. A replacement second hand stereo unit will set you back about £75 -£100. Sorry but thats the best advice i can offer.

Mistydogblue
Set the stereo

Posts : 24
Join date : 2018-08-01

View user profile

Back to top Go down

Re: Wind radio issue

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum